Conoces los Fundamentos necesarios para trabajar con Exchange?

  • Relación con Active Directory y DNS
  • Versiones, CALs y Arquitectura
  • Implementación Híbrida
 
 

Backup Full de las bases de Exchange 2010 con WSB

Los respaldos de bases de datos en Exchange 2010 utilizan VSS, siendo por volumen en todos los casos. Me he encontrado en varias ocasiones con administradores consultando porque no se borran los logs cuando hacen respaldo full y en algunos casos son problemas con el servidor, pero en la mayoría se debe a que no están seleccionando los datos correctamente.

En este artículo vamos a ver como hacer un respaldo full de las bases con Windows Server Backup y como verificar que el mismo haya sido exitoso.

Para realizar el respaldo exitosamente debemos contar con un volumen o disco adicional al de las bases de datos a respaldar (adicionalmente se podría utilizar una unidad de red). Luego con la herramienta de Windows Server Backup seleccionar el o los volúmenes enteros donde se encuentren las bases y logs.

Adicionalmente se debe especificar que el respaldo es full y no de copia (copia es el default).

Importante: Se deben seleccionar los volúmenes completos, no a nivel de carpetas. En cualquiera de los casos el respaldo se realiza correctamente pero seleccionando a nivel de volumen se simplifica el el procedimiento de restore,

Instalar  Windows Server Backup

Primero que nada tenemos que agregar la característica de Windows Server Backup al servidor. Para esto el modo más rápido es utilizando Powershell (como administrador, clic derecho -> Run As -> Administrator):

Import-Module Servermanager

Add-WindowsFeature Backup

add-windowsfeature backup

Nota: Por instrucciones sobre como instalar la característica de backup sobre Windows Server 2012 o Windows Server 2012 R2 ver el siguiente artículo:

https://aprendiendoexchange.com/como-respaldar-las-bases-de-exchange-2013-con-windows-server-backup

Cuándo fue el último respaldo exitoso de la base?

Para validar cuando fue la última vez que se hizo un respaldo completo de la base a en cuestión vamos a las propiedades de la base de datos: Organization configuration -> Mailbox -> Database Management -> General

Ultimo backup completo

En este caso en particular nunca se realizó un respaldo full por lo que “Last Full Backup” no contiene información.

Opcionalmente podemos utilizar el EMS (Exchange Management Shell) para obtener esta información, en caso de trabajar con varias bases es la opción que nos ahorra más tiempo:

Get-MailboxDatabase “base” -status | Select LastFullBackup 

Nota: Si olvidan el parámetro “status” la propiedad siempre se muestra vacía

En este punto ya tenemos Windows Server Backup instalado y verificamos cuando se hizo el último respaldo completo de la base.

Cómo realizar el respaldo?

Para continuar abrir la consola de Windows Server Backup dentro de herramientas administrativas y seguir los pasos a continuación:

  1. Seleccionar Backup Once
  2. En tipo de configuración Custom
  3. En la parte de selección de ítems a respaldar, hacer clic en add y seleccionar el o los volúmenes que contengan base o logsWindows Server Backup - Select items
  4. En Advanced Items – VSS Settings, seleccionar VSS Full BackupVSS full backup
  5. Continuar con el asistente y seleccionar la unidad destino en Backup Destination
  6. Hacer clic en Backup y verificar que finalice exitosamente

Verificar que todo resulto exitoso…

Si todo salió bien se tendrían que haber purgado los logs asociados a la base respaldada.

Adicionalmente podemos verificar nuevamente en las propiedades de la base (o utilizando el EMS):

Ultimo backup completo

En futuros artículos veremos sobre los distintos tipos de backup que hay para Exchange, por ahora si tienen dudas al respecto dejen sus comentarios :D.

En caso de problemas les recomiendo revisar el siguiente artículo:

Por info sobre como respaldar las bases en Exchange 2013 ver el siguiente artículo:

Por último les dejo un artículo sobre como restaurar los datos:

Consultor IT especializado en Microsoft Exchange y Active Directory.
Principales Certificaciones: Microsoft Certified Trainer | Microsoft Certified Solutions Expert | Microsoft Certified Systems Engineer | Microsoft Certified Systems Administrator | Microsoft Certified IT Professional | Microsoft Certified Technology Specialist

21 Responses to Backup Full de las bases de Exchange 2010 con WSB

  1. jesus dice:

    bien detallado, fino

  2. Gustavo S dice:

    Buenas:

    Tengo un problema con mi backup de Exchange 2010 (versión 14.03) que paso a explicar:

    Tengo Exchange en una máquina virtualizada con VmWare y, tengo otra máquina (tambien virtualizada) con el directorio activo. La comunicación entre ambas maquinas, parece correcta.

    El backup lo hago con la aplicación de backups de Windows (Server 2008 R2 Standar, SP 1, en mi caso) y la única diferencia, es que hago el backup con la opción “restauración completa” en lugar de escoger solo la unidad en un backup customizado (en mi caso seria C:) Al final el backup termina con errores (eventos 565, 9782 y 2007) y no borra los logs. Estos errores los veo en el visor de eventos de Windows, en aplicación. En la herramienta de backups, este aparece correcto con warnings.

    Paso a detallar los errores:

    Error 565:

    Error de la comprobación de coherencia del componente ‘—-Chorizo de letras y números—-‘\’Microsoft Exchange Server\Microsoft Information Store\EXCHANGE’. La aplicación ‘Exchange’ no estará disponible en la copia de seguridad creada a las ‘‎—Fecha y hora—‘. Revise los detalles del evento en busca de información sobre los problemas de comprobación de coherencia.
    En detalles, se observa este código de error: 2155479041

    Error 9782:

    VSS Writer de Exchange (instancia—-Chorizo de letras y números—-) completó la copia de seguridad de la base de datos ‘BD01’ con errores, y no se truncaron archivos de registro en esta base de datos.

    Este error ocurre también en otra base de datos llamada BD02. (solo tengo estas dos)

    Error 2007:

    Information Store (6104) Se anuló la instancia de instantánea 3.

    Al pasar un eseutil /k contra BD01, aparecían algunos bad cheksums

    He probado a reparar la base de datos ( eseutil /p y después eseutil /d ), he comprobado que habían desaparecido los bad cheksums pero, el backup ha vuelto a fallar.

    Ahora mismo, estoy un poco perdido. Agradecería cualquier ayuda u orientación para arreglar este problema.

    Muchas gracias.

    • Aprendiendo Exchange dice:

      Hola Gustavo, cuando ejecutas el asistente del respaldo y seleccionas la opción de servidor completo, en la ventana de confirmación (última ventana del wizard) hay una parte que dice “opciones avanzadas” o algo similar, que dice en tu caso? VSS Copy Backup, VSS Full Backup (quiero entender si efectivamente se esta haciendo un backup full).

      Independientemente de lo anterior, como para descartar temas que puedan haber con el procedimiento que estas realizando, si usas los pasos exactos que se detallan en el artículo, se registran los mismos errores? Pasame estos datos y vemos como seguimos.

      saludos!

      • Gustavo dice:

        Buenas de nuevo:

        He cambiado el backup y lo he configurado exactamente igual que en el articulo del blog. Te paso el resultado cuando termine.

        Un saludo 🙂

        • Aprendiendo Exchange dice:

          Excelente Gustavo, veamos como resulta.

          slds!

          • Gustavo dice:

            Buenos dias:

            Terminado el backup con los mismos errores descritos anteriormente (565, 9782 y 2007)

            Un saludo.

          • Aprendiendo Exchange dice:

            Gustavo, el problema entiendo que se pueda estar dando por alguna de las siguientes condiciones:

            a. Corrupción en la base (dado el antecedente mencionado). En este aspecto me gustaría saber si han confirmado que no haya ningun problema a nivel de almacenadmiento en el host vmware y que el antivirus de sistema de archivos (de haber uno) tenga todas las excepciones correspondientes a Exchange (esto puede afectar la integridad de la base)

            b. Problema a nivel de VSS (Volume Shadow Copy Service). En este caso el troubleshooting puede ser bastante extenso pero hay un script que nos facilitaría esto: VSSTester

            Estos errores son frecuentes en entorno de DAG cuando se respalda la copia pasiva sin realizar un cambio específico en el registro, dado que mencionas que usas Windows 2008 R2 Standard sabemos que esto no aplica.

            Procedería del siguiente modo:

            a. Agregar un nuevo disco virtual a la VM que tiene el Exchange. Formatearlo como corresponde (64k). Tener en cuenta que no es una buena práctica tener todo en la unidad del sistema.
            b. Asegurarse que la nueva unidad este dentro de las excepciones del AV y crear una nueva base de datos
            c. Mover un buzón de prueba como para darle algo de carga
            d. Probar de respaldar acorde al procedimiento esta base (la prueba sería bien rapida). Si funciona sabemos que el problema se encuentra en la base original, en ese caso tenemos 2 opciones; reparar la base o mover los buzones a la nueva (veo que usaste eseutil, pero eso sería solo una parte del procedimiento de reparación, de cualquier modo lo ideal sería mover los buzones). La ventaja de mover los buzones en lugar de reparar la base de datos es que primero que nada tenes una base de 0 sin problemas y segundo que durante la movida solo se interrumpe la operativa del usuario puntual que se mueve (y solo al final si usas un cliente que soporte movidas en linea).

            Si el respaldo de la nueva base no funciona es muy probable que el problema se encuentre a nivel de VSS. En este caso utilizaría VSSTester para ver que información arroja:

            https://aprendiendoexchange.com/troubleshooting-de-respaldos-de-exchange-con-vsstester

            Tener en cuenta que podrías empezar por VSSTester y dependiendo del resultado, agregar el disco, etc, pero me parece que con el antecedente de corrupción sería mejor hacer al reves.

            Conta después como te fue.

            slds!

  3. Gustavo dice:

    Buenas de nuevo.

    Sorry por tardar en responder pero este fin de semana estuve fuera y probé a crear la nueva BBDD el domingo por la noche.

    Por desgracia, el backup ha vuelto a fallar. Dejé correr el backup diario y falló como siempre, incluyendo también a la nueva bbdd que había creado (con un buzón que moví).

    Probaré con VSSTester a ver que sucede.Te mantengo informado.

    Gracias por toda la información.

    Saludos!

  4. Gustavo dice:

    He probado VssTester con la BBDD de prueba que me creé y ha ido todo ok. Lo raro es que en el backup diario, esa misma BBDD daba fallo y no truncaba los logs…
    Voy a dejar que corra el backup diario y a ver que pasa. Te voy informando.

    Saludos.

  5. Gustavo dice:

    El backup diario ha fallado como siempre. Ahora mismo no se que mas mirar. El antivirus esta off. No entiendo porque con VssTester se copia esa BBDD sin problemas y en el backup diario, junto con las otras BBDD, falla. Probaré VssTester con la BBDD donde tengo los buzones, a ver que pasa.
    De todos modos… Se te ocurre alguna causa por lo que suceda esto?

    Saludos 🙂

    • Aprendiendo Exchange dice:

      Gustavo, estas probando de largar el backup full de forma manual o estas esperando a que corra el backup diario que comentas?

      Cuando ejecutaste VSSTester, en el visor de sucesos, log de aplicación son todos eventos de información?

      Me gustaría que confirmes como esta la siguiente llave del registro en el servidor:
      HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\WindowsServerBackup\Application Support\

      Debajo de Application Support tendría que aparecer la siguiente llave:
      {76fe1ac4-15f7-4bcd-987e-8e1acb462fb7}

      A la derecha tendrían que aparecer 2 valores de tipo string:
      Application Identifier: Exchange
      CLSID: D8A2E312-3B17-4293-B71E-CD72A7C04BF3

      Confirmame si esto esta bien, de lo contrario puede haber un problema en el registro de la extensión de Windows Server Backup para Exchange

  6. Gustavo dice:

    Estaba esperando que corriera el backup diario pero, he probado a lanzar uno yo, obteniendo mismo resultado y mismos fallos.

    Despues de ejecutar VssTester, los eventos eran todos de informacion, si.

    He comprobado el registro y tiene los mismos valores que indicas.

    Me queda probar VssTester en la BBDD que contiene los buzones. Pruebo esta noche y te digo algo.

  7. Gustavo dice:

    Buenas:

    Lo ultimo que hice, fue correr VssTester en la BBDD de los buzones. Todo fue ok.
    El backup sigue fallando. Entiendo que si funciona VssTester, el problema no esta en Exchange, verdad? Ademas, las comprobaciones con eseutil /k devuelven 0 errores.
    Voy a investigar algo mas a nivel de SO.

    Si se te ocurre alguna idea, bienvenida sea 🙂

    Un saludo!

    • Aprendiendo Exchange dice:

      Hola Gustavo, sería bueno investigar sobre posibles dependencias. Como bien decis habría que ver a nivel de OS, quizás algo más de fondo en la instalación de Exchange.
      Avisa cualquier novedad.

      slds!

  8. Gustavo dice:

    Buenas y sorry por tardar en responder pero, estaba en un cliente y no he podido atender el tema 🙂

    Al final lo ha solucionado un compañero, que lo retomó donde yo lo dejé, y el backup termina sin fallos. Explico lo realizado.

    Se desmontó la BBDD BD01 y se lanzó un eseutil contra los log de la BBDD ( E00….) obteniendo errores. Se movieron todos los log a otra carpeta para que al montar la BBDD se crearan de nuevo. La copia seguía con errores y se observó que la BBDD volvía a dar fallos tras realizar un eseutil. Se hizo una reparación de la BBDD y el backup terminó correctamente.

    La verdad, no entiendo por qué si los log estaban mal, fallaban el resto de BBDD (que yo sepa, esto de los log, solo se hizo de la BD01)

    En fin, eso es todo. Espero ayudar a los que tengan un problema parecido.

    Cualquier pregunta, estaré encantado de responder 🙂

    Gracias por la ayuda!

    Un saludo

    • Aprendiendo Exchange dice:

      Hola Gustavo, me alegra que ya esten pudiendo respaldar las bases.
      Me parece un poco extraño como se resolvió el tema ya que en su momento habías probado con una base nueva y los errores se repetian pero vaya a saber uno que otra cosa pudo haber pasado entre tanta vuelta.
      Suerte y a las órdenes por cualquier consulta.

      saludos!

  9. Gustavo dice:

    Buenas de nuevo 🙂

    Yo pienso lo mismo que tu. No entiendo el motivo de que las otras bases fallaran tambien en la copia. Puede bastar solo una base mal para que el backup tenga errores al copiar las demas… No se.

    Por cierto, decir que hemos movido todos los buzones a una nueva BBDD y BD01 ha sido eliminada.
    Habia unos cuantos buzones dañados que no se podian mover pero, al final conseguimos hacerlo y parece que esta todo ok.

    Un saludo!

Responder a jesus Cancelar respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Registrarse


Mostrar botones
Ocultar botones