Error al abrir las consolas de administración de Exchange 2010

Me encontré con este problema hace unos días. El cliente me contactó luego de que por un reinicio espontaneo del controlador de dominio del sitio de Exchange no pudiera abrir el Shell (EMS) ni la EMC. Cuando me conecte al servidor lo primero que hice fue abrir la consola de servicios a ver cual estaba abajo, sin embargo estaban todos arriba. Probe de crear una sesión manual con Windows Powershell y tampoco funcionó (a veces cuando no funcionan las consolas es posible conectarse utilizando el Powershell como se indica en este artículo).

El error era el siguiente:

[Servidor.dominio.com] Connecting to remote server failed with the following error message: The WS-Management service cannot process the request. The system load quota of 1000 requests per 2 seconds has been exceeded. Send future requests at a slower rate or raise the system quota. The next request from this user will not be approved for at least XXXXX milliseconds. For more information, see the about_Remote_Troubleshooting Help topic.

                +CategoryInfo   : OpenError: (System.Manageme….RemoteRunspace:RemoteRunspace) [], PSRemotingTransportException

                +FullyQualifiedErrorId  :  PSSessionOpenFailed

Cómo se resolvió?

Si bien parece un error trágico simplemente un IISRESET  -noforce desde el CMD alcanzó para solucionarlo pero un reinicio también habría funcionado.

Por último a tener en cuenta que después de ejecutar IISRESET algunos servicios pueden quedar abajo (por ejemplo el WWW), por lo que recomiendo que luego de ejecutarlo abran la consola de servicios, ordenen los mismos por automático y revisen si alguno no figura como “Started(en ese caso iniciarlo).

Artículos relacionados:

About Daniel Núñez Banega

Consultor IT especializado en Microsoft Exchange, Active Directory y Microsoft 365.
Principales Certificaciones: Microsoft Certified Trainer | Microsoft Certified Solutions Expert | Microsoft Certified Systems Engineer | Microsoft Certified Systems Administrator | Microsoft Certified IT Professional | Microsoft Certified Technology Specialist | Microsoft 365 Certified: Enterprise Administrator Expert | Microsoft 365 Certified: Security Administrator Associate | Comptia Pentest+

Reader Interactions

Comments

  1. Martin says

    tengo un problema que la EMC se abre como un usuario sin permisos, por lo tanto, no puedo ver los certificaods instalador para renovarlos. alguna idea?

    • Aprendiendo Exchange says

      Hola Martin, desde el shell podes ejecutar el comando Get-Exchangecertificate ?
      Verificaste la membresía de grupos del usuario que estas utilizando?

      • Martin says

        me da error de acceso denegado y esto aparece en el visor
        Get-ExchangeCertificate
        {Thumbprint=?}
        midominio.local.com/Users/carolina canepa
        S-1-5-21-2040188963-524099950-743784304-1410
        S-1-5-21-2040188963-524099950-743784304-1410
        ServerRemoteHost-Unknown
        9664

        6
        00:00:00.0310018
        Ver todo el bosque: ‘False’, Ámbito predeterminado: «midominio.local.com», Configuración del controlador de dominio: «servidor1.midominio.local.com», Catálogo global preferido: «servidor1.midominio.local.com», Controladores de dominio preferidos: «{ servidor1.midominio.local.com }»
        Microsoft.Exchange.Data.Common.LocalizedException: Error de operación del certificado de Exchange con una excepción. Mensaje de error: Acceso denegado —> System.ComponentModel.Win32Exception: Acceso denegado — Fin del seguimiento de la pila de la excepción interna —
        7
        System.ComponentModel.Win32Exception: Acceso denegado

        lo mas raro es que el usuario no es administrador, pero le di permisos de administracion en la RAB

        • Aprendiendo Exchange says

          Bien, sería ideal saber si es un problema a nivel de consolas del servidor. Primero que nada, hace mucho que no se reinicia el servidor? probaste reiniciarlo (levanta todos los servicios?)? Si entras al servidor con el usuario administrator o un usuario miembro del grupo Organization Management te da el mismo error o es solo con esta cuenta?
          Si te da el mismo error se podría probar desde powershell directamente siguiendo el procedimiento detallado en el siguiente artículo: https://aprendiendoexchange.com/powershell-como-conectarse-remoto-a-exchange2010

          Proba eso y contame como te fue.

          • Martin says

            probe la conexion remota por el powershell, siguiendo la pagina que me indicas y no hay problemas.
            pero desde la EMC sigue el error

          • Aprendiendo Exchange says

            El artículo indica como iniciar el shell remoto desde powershell como alternativa cuando no estás en el servidor o las consolas no te abren, es decir que esto no te va a resolver el tema pero te permite acceder y ver configuración, etc. Probaste con otra cuenta de usuario? reiniciaste el servidor? estan todos los servicios levantados? El Exchange está actualizado? estas corriendo el último service pack, etc? Conviene primero verificar todo lo básico.

  2. Ricardo says

    Hola, en la consola de Exchange 2010 me aparece el siguiente mensaje: Error de conexión al servidor remoto. Mensaje de error: El cliente WinRM recibió un código de estado HTTP de 303 del servicio WS-Management remoto

    Qué puede ser? No puedo acceder a la consola para administrar mi servidor

    • Daniel Núñez Banega says

      Hola Ricardo, el tema se puede deber a múltiples cosas, lo primero que probaría sería reiniciar los servicios asociados a IIS o reiniciar el servidor.

  3. Adrian says

    buenas tardes, me gustaría consultarte una cuestión que tengo en un ambiente de exchange 2010 sp3, distribuidos en dos servidores diferentes uno de ellos, me presenta un error al asignar permisos sobre una cuenta de correo ejemplo para dar permisos de buzón, el error viene después de un cambio de domain controller secundario el cual es dns tambien, lo tuve que recrear haciendo uno nuevo y pasarle los correspondientes roles fsmo. En uno solo de los exchange me aparece esto al querer hacer algun cambio de permisos. (a tener en cuenta el error lo da igual y aveces aplica los permisos por mas que de el error) ya reinicie ambos servidores DC y Exchange, si me fijo en el EMC configuracion de servidor – acceso al cliente y veo los servidores que usa de controlador de dominio y global catalogo usa los dos que tengo en funcionamiento asi y todo me surje este error:

    Error en la operacion de Activer Directory en «mi servidor xxxxx». Este error puede deberse a la acción del usuario o a que el servidor de Active Directory no esta disponible. Vuelva a intertarlo mas tarde. Informacion adicional. Informacion Adicional: Error de comprobacion del catagolo global. Este no esta disponible o no es compatible con la operacion . Aguna parte del directorio no esta actualmente disponible.
    Respues de Active directory: 000020E1: SvcErr: DSID-03200C50, problem 5002 (UNAVAILABLE) data 0 estaba ejencuntando el comando ‘Add-MailboxPermissio -Identity «xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx» -AccesRights ‘FullAccess’

    • Daniel Núñez Banega says

      Hola Adrian, seguramente algo no haya quedado bien actualizado, sería bueno confirmar si es un «problema» o es algo que está afectando la consola.
      Una buena prueba en este sentido sería ejecutar el comando directamente desde el Shell de Exchange y ver si se da el error.
      Dependiendo de esto cómo avanzar.

Deja una respuesta

Tu dirección de correo electrónico no será publicada.